using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\S)programming language(?![^\s.!?])|(?<!\S)programming(?![^\s.!?])|(?<!\S)language(?![^\s.!?])";
string input = @"A programming language is a formal language that specifies a set of instructions that can be used to produce various kinds of output. programming languages generally consist of instructions for a computer.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}