import Foundation
let pattern = #"(?<!\S)programming language(?![^\s.!?])|(?<!\S)programming(?![^\s.!?])|(?<!\S)language(?![^\s.!?])"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"A programming language is a formal language that specifies a set of instructions that can be used to produce various kinds of output. programming languages generally consist of instructions for a computer."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)