import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<div class=\"([^\"]+)\">.+<div class=\"child-same-class\">)";
final String string = "<div class=\"parent-first-class\">\n"
+ " <div class=\"child-same-class\">\n\n"
+ "<div class=\"parent-second-class\">\n"
+ " <div class=\"child-same-class\">\n\n"
+ "<div class=\"parent-third-class\">\n"
+ " <div class=\"child-same-class\">";
final String subst = "$1\\n\\t<xf:if is=\"'$2' == 'parent-second-class'>...</xf:if>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.DOTALL | Pattern.UNICODE_CHARACTER_CLASS);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}