// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?isU)(<div class="([^"]+)">.+<div class="child-same-class">)"#).unwrap();
let string = "<div class=\"parent-first-class\">
<div class=\"child-same-class\">
<div class=\"parent-second-class\">
<div class=\"child-same-class\">
<div class=\"parent-third-class\">
<div class=\"child-same-class\">";
let substitution = "$1\\n\\t<xf:if is=\"'$2' == 'parent-second-class'>...</xf:if>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}