$re = '#(<div class="([^"]+)">.+<div class="child-same-class">)#isU';
$str = '<div class="parent-first-class">
<div class="child-same-class">
<div class="parent-second-class">
<div class="child-same-class">
<div class="parent-third-class">
<div class="child-same-class">';
$subst = "$1\n\t<xf:if is=\"'$2' == 'parent-second-class'>...</xf:if>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;