package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^.*[vV][1-9]\d*(\.\d+)*$`)
var str = `Abc abc bejfir v1.0
Testing this v1.1.1
Testing V1.0
And not marching if v1.0 is not there. So not matching
Testing
Testing something more
Testing 3.1 something
Testing 3.1
Thabks in advance `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}