// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^.*[vV][1-9]\d*(\.\d+)*$").unwrap();
let string = "Abc abc bejfir v1.0
Testing this v1.1.1
Testing V1.0
And not marching if v1.0 is not there. So not matching
Testing
Testing something more
Testing 3.1 something
Testing 3.1
Thabks in advance ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}