import re
regex = re.compile(r"^.*[vV][1-9]\d*(\.\d+)*$", flags=re.MULTILINE)
test_str = ("Abc abc bejfir v1.0\n\n"
"Testing this v1.1.1\n\n"
"Testing V1.0\n\n"
"And not marching if v1.0 is not there. So not matching \n\n"
"Testing\n\n"
"Testing something more\n\n"
"Testing 3.1 something \n\n"
"Testing 3.1\n\n"
"Thabks in advance ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")