import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*[vV][1-9]\\d*(\\.\\d+)*$";
final String string = "Abc abc bejfir v1.0\n\n"
+ "Testing this v1.1.1\n\n"
+ "Testing V1.0\n\n"
+ "And not marching if v1.0 is not there. So not matching \n\n"
+ "Testing\n\n"
+ "Testing something more\n\n"
+ "Testing 3.1 something \n\n"
+ "Testing 3.1\n\n"
+ "Thabks in advance ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}