use strict;
my $str = 'Abc abc bejfir v1.0
Testing this v1.1.1
Testing V1.0
And not marching if v1.0 is not there. So not matching
Testing
Testing something more
Testing 3.1 something
Testing 3.1
Thabks in advance ';
my $regex = qr/^.*[vV][1-9]\d*(\.\d+)*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}