import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!\\d+$)(([1-9]\\d*)?[Dd]?[1-9]\\d*( ?[+-] ?)?)+(?<![+-] ?)$";
final String string = "**WORKS**\n"
+ "d20\n"
+ "2D12+ 4 - 2\n"
+ "12d4-2d6+7 + d8\n"
+ "7 + 1d12\n\n"
+ "**DOESN'T WORK**\n"
+ "-2d6+4\n"
+ "-d8 - 5\n"
+ "12\n"
+ "2d0 + 5\n"
+ "1d6 + 0d2 - 1\n"
+ "0d6\n"
+ "100d\n"
+ "d\n"
+ "7d4+\n"
+ "1+";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}