# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?!\d+$)(([1-9]\d*)?[Dd]?[1-9]\d*( ?[+-] ?)?)+(?<![+-] ?)$"
test_str = ("**WORKS**\n"
"d20\n"
"2D12+ 4 - 2\n"
"12d4-2d6+7 + d8\n"
"7 + 1d12\n\n"
"**DOESN'T WORK**\n"
"-2d6+4\n"
"-d8 - 5\n"
"12\n"
"2d0 + 5\n"
"1d6 + 0d2 - 1\n"
"0d6\n"
"100d\n"
"d\n"
"7d4+\n"
"1+")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.