const regex = /^(?!\d+$)(([1-9]\d*)?[Dd]?[1-9]\d*( ?[+-] ?)?)+(?<![+-] ?)$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!\\d+$)(([1-9]\\d*)?[Dd]?[1-9]\\d*( ?[+-] ?)?)+(?<![+-] ?)$', 'mg')
const str = `**WORKS**
d20
2D12+ 4 - 2
12d4-2d6+7 + d8
7 + 1d12
**DOESN'T WORK**
-2d6+4
-d8 - 5
12
2d0 + 5
1d6 + 0d2 - 1
0d6
100d
d
7d4+
1+`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}