$re = '/^(?!\d+$)(([1-9]\d*)?[Dd]?[1-9]\d*( ?[+-] ?)?)+(?<![+-] ?)$/m';
$str = '**WORKS**
d20
2D12+ 4 - 2
12d4-2d6+7 + d8
7 + 1d12
**DOESN\'T WORK**
-2d6+4
-d8 - 5
12
2d0 + 5
1d6 + 0d2 - 1
0d6
100d
d
7d4+
1+';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);