use strict;
my $str = '**WORKS**
d20
2D12+ 4 - 2
12d4-2d6+7 + d8
7 + 1d12
**DOESN\'T WORK**
-2d6+4
-d8 - 5
12
2d0 + 5
1d6 + 0d2 - 1
0d6
100d
d
7d4+
1+';
my $regex = qr/^(?!\d+$)(([1-9]\d*)?[Dd]?[1-9]\d*( ?[+-] ?)?)+(?<![+-] ?)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}