package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)MyFunction\(((?:[^()]++|\((?1)\))*)\)`)
var str = `MyFunction(23)
MyFunction('Sekret')
MyFunction( 23, 'Sekret', Date() )
MyFunction( Encrypt('Sekret'), Date() )
logger.info("MyFunction( Encrypt('Sekret'), Date() )")
MyFunction(as(()((das)))()(das(((das))))))
MyFunction( Encrypt('Sekret'), Bla(Date()) )
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}