// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)MyFunction\(((?:[^()]++|\((?1)\))*)\)").unwrap();
let string = "MyFunction(23)
MyFunction('Sekret')
MyFunction( 23, 'Sekret', Date() )
MyFunction( Encrypt('Sekret'), Date() )
logger.info(\"MyFunction( Encrypt('Sekret'), Date() )\")
MyFunction(as(()((das)))()(das(((das))))))
MyFunction( Encrypt('Sekret'), Bla(Date()) )
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}