$re = '/MyFunction\(((?:[^()]++|\((?1)\))*)\)/m';
$str = 'MyFunction(23)
MyFunction(\'Sekret\')
MyFunction( 23, \'Sekret\', Date() )
MyFunction( Encrypt(\'Sekret\'), Date() )
logger.info("MyFunction( Encrypt(\'Sekret\'), Date() )")
MyFunction(as(()((das)))()(das(((das))))))
MyFunction( Encrypt(\'Sekret\'), Bla(Date()) )
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);