const regex = /MyFunction\(((?:[^()]++|\((?1)\))*)\)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('MyFunction\\(((?:[^()]++|\\((?1)\\))*)\\)', 'gm')
const str = `MyFunction(23)
MyFunction('Sekret')
MyFunction( 23, 'Sekret', Date() )
MyFunction( Encrypt('Sekret'), Date() )
logger.info("MyFunction( Encrypt('Sekret'), Date() )")
MyFunction(as(()((das)))()(das(((das))))))
MyFunction( Encrypt('Sekret'), Bla(Date()) )
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}