#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)r'\d+(?<![.,])[,|.]\d{2}(?![.,]\d)'"
Local $sString = " ['1,000.45', '100.45', '7.89 ', '9769.71.046491.7', '123.45', '123', '1.234', '1,2', ' 10.00','12.09.21','210.00', '25.00', '238,50','4,34,34']"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")