using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"r'\d+(?<![.,])[,|.]\d{2}(?![.,]\d)'";
string input = @" ['1,000.45', '100.45', '7.89 ', '9769.71.046491.7', '123.45', '123', '1.234', '1,2', ' 10.00','12.09.21','210.00', '25.00', '238,50','4,34,34']";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}