import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "r'\\d+(?<![.,])[,|.]\\d{2}(?![.,]\\d)'";
final String string = " ['1,000.45', '100.45', '7.89 ', '9769.71.046491.7', '123.45', '123', '1.234', '1,2', ' 10.00','12.09.21','210.00', '25.00', '238,50','4,34,34']";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}