use strict;
my $str = ' [\'1,000.45\', \'100.45\', \'7.89 \', \'9769.71.046491.7\', \'123.45\', \'123\', \'1.234\', \'1,2\', \' 10.00\',\'12.09.21\',\'210.00\', \'25.00\', \'238,50\',\'4,34,34\']';
my $regex = qr/r'\d+(?<![.,])[,|.]\d{2}(?![.,]\d)'/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}