import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((-?\\d+(?:\\.\\d+)?)(?:[*+/^eE-]| (?:to the power of|plus|add|minus|subtract|divided?|times|multipl(?:y|ied))(?: by)?)(?: )?)(?1)*(?2)$";
final String string = "2*2\n"
+ "2+2\n"
+ "2/2\n"
+ "2-2\n"
+ "2^2-2\n"
+ "2^2\n"
+ "2e10^4\n\n"
+ "2^2^2^2+4\n"
+ "2+2+2+2\n"
+ "2 times 2\n"
+ "2 multiplied by 2\n"
+ "2 multiply 2\n"
+ "2 divide 2\n"
+ "2 divided by 2\n"
+ "2 add 2\n"
+ "2 plus 2\n"
+ "2 minus 2\n"
+ "2 subtract 2\n"
+ "2 to the power of 2 divided by 10\n"
+ "2 multiplied by 10 times 3\n"
+ "2.09187 times 9\n"
+ "-3 times 9\n"
+ "2+-6\n\n"
+ "2 multiplied by";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}