import Foundation
let pattern = #"^((-?\d+(?:\.\d+)?)(?:[*+/^eE-]| (?:to the power of|plus|add|minus|subtract|divided?|times|multipl(?:y|ied))(?: by)?)(?: )?)(?1)*(?2)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
2*2
2+2
2/2
2-2
2^2-2
2^2
2e10^4
2^2^2^2+4
2+2+2+2
2 times 2
2 multiplied by 2
2 multiply 2
2 divide 2
2 divided by 2
2 add 2
2 plus 2
2 minus 2
2 subtract 2
2 to the power of 2 divided by 10
2 multiplied by 10 times 3
2.09187 times 9
-3 times 9
2+-6
2 multiplied by
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)