const regex = new RegExp('^((-?\\d+(?:\\.\\d+)?)(?:[*+/^eE-]| (?:to the power of|plus|add|minus|subtract|divided?|times|multipl(?:y|ied))(?: by)?)(?: )?)(?1)*(?2)$', 'gm')
const str = `2*2
2+2
2/2
2-2
2^2-2
2^2
2e10^4
2^2^2^2+4
2+2+2+2
2 times 2
2 multiplied by 2
2 multiply 2
2 divide 2
2 divided by 2
2 add 2
2 plus 2
2 minus 2
2 subtract 2
2 to the power of 2 divided by 10
2 multiplied by 10 times 3
2.09187 times 9
-3 times 9
2+-6
2 multiplied by`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}