# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^((-?\d+(?:\.\d+)?)(?:[*+/^eE-]| (?:to the power of|plus|add|minus|subtract|divided?|times|multipl(?:y|ied))(?: by)?)(?: )?)(?1)*(?2)$"
test_str = ("2*2\n"
"2+2\n"
"2/2\n"
"2-2\n"
"2^2-2\n"
"2^2\n"
"2e10^4\n\n"
"2^2^2^2+4\n"
"2+2+2+2\n"
"2 times 2\n"
"2 multiplied by 2\n"
"2 multiply 2\n"
"2 divide 2\n"
"2 divided by 2\n"
"2 add 2\n"
"2 plus 2\n"
"2 minus 2\n"
"2 subtract 2\n"
"2 to the power of 2 divided by 10\n"
"2 multiplied by 10 times 3\n"
"2.09187 times 9\n"
"-3 times 9\n"
"2+-6\n\n"
"2 multiplied by")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.