// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^((-?\d+(?:\.\d+)?)(?:[*+/^eE-]| (?:to the power of|plus|add|minus|subtract|divided?|times|multipl(?:y|ied))(?: by)?)(?: )?)(?1)*(?2)$").unwrap();
let string = "2*2
2+2
2/2
2-2
2^2-2
2^2
2e10^4
2^2^2^2+4
2+2+2+2
2 times 2
2 multiplied by 2
2 multiply 2
2 divide 2
2 divided by 2
2 add 2
2 plus 2
2 minus 2
2 subtract 2
2 to the power of 2 divided by 10
2 multiplied by 10 times 3
2.09187 times 9
-3 times 9
2+-6
2 multiplied by";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}