using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(((25[0-5])|(2[0-4]\d)|(1\d{2})|(\d{1,2}))\.){3}(((25[0-5])|(2[0-4]\d)|(1\d{2})|(\d{1,2})))";
string input = @"1.1.1.1
254.2.2.2.
255.1.1.255
256.1.1.256
012.111.111.111
12.12.12.12a
1q.1.1.1
1.1q.1.1
1.1.1q.1
1.1.1.1q
abcde254.2.2.2";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}