import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(((25[0-5])|(2[0-4]\\d)|(1\\d{2})|(\\d{1,2}))\\.){3}(((25[0-5])|(2[0-4]\\d)|(1\\d{2})|(\\d{1,2})))";
final String string = "1.1.1.1\n"
+ "254.2.2.2.\n"
+ "255.1.1.255\n"
+ "256.1.1.256\n"
+ "012.111.111.111\n"
+ "12.12.12.12a\n"
+ "1q.1.1.1\n"
+ "1.1q.1.1\n"
+ "1.1.1q.1\n"
+ "1.1.1.1q\n"
+ "abcde254.2.2.2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}