import re
regex = re.compile(r"(((25[0-5])|(2[0-4]\d)|(1\d{2})|(\d{1,2}))\.){3}(((25[0-5])|(2[0-4]\d)|(1\d{2})|(\d{1,2})))", flags=re.MULTILINE)
test_str = ("1.1.1.1\n"
"254.2.2.2.\n"
"255.1.1.255\n"
"256.1.1.256\n"
"012.111.111.111\n"
"12.12.12.12a\n"
"1q.1.1.1\n"
"1.1q.1.1\n"
"1.1.1q.1\n"
"1.1.1.1q\n"
"abcde254.2.2.2")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")