using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\-flac$";
string input = @"http://6tor.org/torrent/899790/va-relax-with-beethoven-2022-mp3
http://6tor.org/torrent/899789/h%C3%A9l%C3%A8ne-grimaud-piano-essentials-2022-mp3
http://6tor.org/torrent/899781/shotgun-surgery-shiteater-2022-flac
http://6tor.org/torrent/899778/jelektrichestvo-akvarium-2022-flac
http://6tor.org/torrent/899788/elisabeth-leonskaja-piano-essentials-2022-mp3
http://6tor.org/torrent/899787/bertrand-chamayou-piano-essentials-2022-mp3";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}