use strict;
my $str = 'http://6tor.org/torrent/899790/va-relax-with-beethoven-2022-mp3
http://6tor.org/torrent/899789/h%C3%A9l%C3%A8ne-grimaud-piano-essentials-2022-mp3
http://6tor.org/torrent/899781/shotgun-surgery-shiteater-2022-flac
http://6tor.org/torrent/899778/jelektrichestvo-akvarium-2022-flac
http://6tor.org/torrent/899788/elisabeth-leonskaja-piano-essentials-2022-mp3
http://6tor.org/torrent/899787/bertrand-chamayou-piano-essentials-2022-mp3';
my $regex = qr/\-flac$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}