import Foundation
let pattern = #"\-flac$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
http://6tor.org/torrent/899790/va-relax-with-beethoven-2022-mp3
http://6tor.org/torrent/899789/h%C3%A9l%C3%A8ne-grimaud-piano-essentials-2022-mp3
http://6tor.org/torrent/899781/shotgun-surgery-shiteater-2022-flac
http://6tor.org/torrent/899778/jelektrichestvo-akvarium-2022-flac
http://6tor.org/torrent/899788/elisabeth-leonskaja-piano-essentials-2022-mp3
http://6tor.org/torrent/899787/bertrand-chamayou-piano-essentials-2022-mp3
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)