import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\-flac$";
final String string = "http://6tor.org/torrent/899790/va-relax-with-beethoven-2022-mp3\n"
+ "http://6tor.org/torrent/899789/h%C3%A9l%C3%A8ne-grimaud-piano-essentials-2022-mp3\n"
+ "http://6tor.org/torrent/899781/shotgun-surgery-shiteater-2022-flac\n"
+ "http://6tor.org/torrent/899778/jelektrichestvo-akvarium-2022-flac\n"
+ "http://6tor.org/torrent/899788/elisabeth-leonskaja-piano-essentials-2022-mp3\n"
+ "http://6tor.org/torrent/899787/bertrand-chamayou-piano-essentials-2022-mp3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}