# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\-flac$"
test_str = ("http://6tor.org/torrent/899790/va-relax-with-beethoven-2022-mp3\n"
"http://6tor.org/torrent/899789/h%C3%A9l%C3%A8ne-grimaud-piano-essentials-2022-mp3\n"
"http://6tor.org/torrent/899781/shotgun-surgery-shiteater-2022-flac\n"
"http://6tor.org/torrent/899778/jelektrichestvo-akvarium-2022-flac\n"
"http://6tor.org/torrent/899788/elisabeth-leonskaja-piano-essentials-2022-mp3\n"
"http://6tor.org/torrent/899787/bertrand-chamayou-piano-essentials-2022-mp3")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.