import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\n(.*)\\n\\n";
final String string = "Russell L. Jones\n\n"
+ "Real Estate Lawyers Serving Advance, IN (Carmel, Indiana) \n\n"
+ "www.russelljoneslaw.com/\n\n"
+ "A real estate firm representing businesses and individuals in Carmel, Indiana and statewide. ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}