#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\R+(\z)?"
Local $sString = "2400 Highway 31 SW" & @CRLF & _
"" & @CRLF & _
"FooBar" & @CRLF & _
"" & @CRLF & _
"AL" & @CRLF & _
"" & @CRLF & _
"37770" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = "${1:+: }"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)