$re = '/\R+(\z)?/m';
$str = '2400 Highway 31 SW
FooBar
AL
37770
';
$subst = "${1:+: }";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;