re = /\R+(\z)?/m
str = '2400 Highway 31 SW
FooBar
AL
37770
'
subst = '${1:+: }'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result