// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\R+(\z)?").unwrap();
let string = "2400 Highway 31 SW
FooBar
AL
37770
";
let substitution = "${1:+: }";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}