using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\R+(\z)?";
string substitution = @"${1:+: }";
string input = @"2400 Highway 31 SW
FooBar
AL
37770
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}