import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:https?://)?(?:www\\.)?test\\.com(?:/subfolder)?/?(?:\\?\\S*)?$";
final String string = "test.com\n"
+ "https://test.com\n"
+ "https://test.com?foo=bar\n"
+ "https://test.com/\n"
+ "https://test.com/?foo=bar\n"
+ "https://www.test.com\n"
+ "https://www.test.com/subfolder\n"
+ "https://www.test.com/subfolder/\n"
+ "https://www.test.com/subfolder/?foo=bar\n"
+ "test.com/subfolder\n"
+ "https://www.test.com/foo\n"
+ "test.com/foo\n"
+ "https://www.test.com/jason\n"
+ "https://www.test.com/jason?foo=bar";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}