import re
regex = re.compile(r"^(?:https?://)?(?:www\.)?test\.com(?:/subfolder)?/?(?:\?\S*)?$", flags=re.MULTILINE)
test_str = ("test.com\n"
"https://test.com\n"
"https://test.com?foo=bar\n"
"https://test.com/\n"
"https://test.com/?foo=bar\n"
"https://www.test.com\n"
"https://www.test.com/subfolder\n"
"https://www.test.com/subfolder/\n"
"https://www.test.com/subfolder/?foo=bar\n"
"test.com/subfolder\n"
"https://www.test.com/foo\n"
"test.com/foo\n"
"https://www.test.com/jason\n"
"https://www.test.com/jason?foo=bar")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")