const regex = new RegExp('^(?:https?://)?(?:www\\.)?test\\.com(?:/subfolder)?/?(?:\\?\\S*)?$', 'gm')
const str = `test.com
https://test.com
https://test.com?foo=bar
https://test.com/
https://test.com/?foo=bar
https://www.test.com
https://www.test.com/subfolder
https://www.test.com/subfolder/
https://www.test.com/subfolder/?foo=bar
test.com/subfolder
https://www.test.com/foo
test.com/foo
https://www.test.com/jason
https://www.test.com/jason?foo=bar`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}