// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:https?://)?(?:www\.)?test\.com(?:/subfolder)?/?(?:\?\S*)?$").unwrap();
let string = "test.com
https://test.com
https://test.com?foo=bar
https://test.com/
https://test.com/?foo=bar
https://www.test.com
https://www.test.com/subfolder
https://www.test.com/subfolder/
https://www.test.com/subfolder/?foo=bar
test.com/subfolder
https://www.test.com/foo
test.com/foo
https://www.test.com/jason
https://www.test.com/jason?foo=bar";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}