$re = '~^(?:https?://)?(?:www\.)?test\.com(?:/subfolder)?/?(?:\?\S*)?$~m';
$str = 'test.com
https://test.com
https://test.com?foo=bar
https://test.com/
https://test.com/?foo=bar
https://www.test.com
https://www.test.com/subfolder
https://www.test.com/subfolder/
https://www.test.com/subfolder/?foo=bar
test.com/subfolder
https://www.test.com/foo
test.com/foo
https://www.test.com/jason
https://www.test.com/jason?foo=bar';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);