using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"-\$[0-9]{1,3}";
string input = @"{""amount"":1242,""amountFormatted"":""-$1,242"",""currency"":""USD"",""type"":""PRICING"",""__typename"":""PriceItem""},{""localizedTitle"":""Fees"",""localizedExplanation"":""This fee covers: ""} ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}