// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)-\$[0-9]{1,3}").unwrap();
let string = "{\"amount\":1242,\"amountFormatted\":\"-$1,242\",\"currency\":\"USD\",\"type\":\"PRICING\",\"__typename\":\"PriceItem\"},{\"localizedTitle\":\"Fees\",\"localizedExplanation\":\"This fee covers: \"} ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}