package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)-\$[0-9]{1,3}`)
var str = `{"amount":1242,"amountFormatted":"-$1,242","currency":"USD","type":"PRICING","__typename":"PriceItem"},{"localizedTitle":"Fees","localizedExplanation":"This fee covers: "} `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}